Cadastral Records Enquiry (CRE) Search Performance Issues

Incident Report for NSW LRS

Resolved

CRE Search performance issue resolved.
Posted Feb 12, 2026 - 21:09 AEDT

Identified

This issue has been identified, and our third-party service provider is investigating the possible solution.
Posted Feb 10, 2026 - 17:16 AEDT

Investigating

The CRE Search service is currently experiencing degraded performance. CRE Maps and Image request may not be returning the search documents.

Our third-party service provider has been engaged. We will provide updates as the situation progresses.
Posted Feb 10, 2026 - 14:13 AEDT
This incident affected: NSW LRS Online Portal Service (Cadastral Records Enquiry).