Cadastral Records Enquiry (CRE) Search Performance Issues

Incident Report for NSW LRS

Monitoring

CRE Search service has stablised.
Posted Feb 24, 2026 - 12:33 AEDT

Investigating

The CRE Search service is currently experiencing degraded performance. CRE Maps and Image request may be taking a long time returning the search documents. Please avoid resubmitting search requests multiple times, as this will increase the system load.

Our third-party service provider has been engaged. We will provide updates as the situation progress.
Posted Feb 23, 2026 - 11:23 AEDT
This incident affects: NSW LRS Online Portal Service (Cadastral Records Enquiry).