Cadastral Records Enquiry (CRE) Search Issue

Incident Report for NSW LRS

Resolved

This incident has been resolved.
Posted Dec 17, 2025 - 08:36 AEDT

Monitoring

Our third-party service provider has implemented a fix and CRE service restored. We will continue to monitor the issue to ensure system integrity.
Posted Dec 16, 2025 - 21:16 AEDT

Investigating

Our third-party service provider is working on resolving the issue and we will provide updates as the situation progresses.
Posted Dec 16, 2025 - 20:08 AEDT

Monitoring

CRE search service is stablised. We will continue to monitor to ensure system integrity.
Posted Dec 16, 2025 - 18:54 AEDT

Investigating

The Cadastral Records Enquiry search service is currently experiencing issues. CRE Maps and Image request is intermittently unavailable.

Our third-party service provider is working on resolving the issue and we will provide updates as the situation progresses.
Posted Dec 16, 2025 - 16:38 AEDT
This incident affected: NSW LRS Online Portal Service (Cadastral Records Enquiry).