Cadastral Records Enquiry (CRE) Search Performance Issues

Incident Report for NSW LRS

Update

Our third-party service provider is continuing to work on a fix to restore the service.
Posted Sep 11, 2026 - 09:28 AEST

Update

This issue has been identified, and our third-party service provider is implementing the possible solution.
Posted Sep 10, 2026 - 12:45 AEST

Identified

The CRE Search service is currently experiencing issues intermittently. CRE Maps and Image request may be taking a long time or may not be returning the search document. Please avoid resubmitting search requests multiple times, as this will increase the system load.

Our third-party service provider has been engaged. We will provide updates as the situation progresses.
Posted Sep 10, 2026 - 11:16 AEST