Street Address Inquiry service unavailable
Incident Report for NSW LRS
Resolved
The Street Address Inquiry Search Service is restored.
Posted Jun 20, 2022 - 14:59 AEST
Investigating
We're currently experiencing an issue with Street Address Inquiry search service. Our technical team have engaged our third party service provider and we will return with an update as the situation develops.
Posted Jun 20, 2022 - 13:17 AEST
This incident affected: NSW LRS Online Portal Service (Street Address searches).